Directory Deletion Issue

1 year 2 months ago #319 by Kahuna
Replied by Kahuna on topic Directory Deletion Issue
I am updating package cleanups for version 1.7. I'll see if I can reproduce and fix as part of that.

Please Log in or Create an account to join the conversation.

1 year 3 months ago #317 by RorySRut
Directory Deletion Issue was created by RorySRut

A packager did a package that had an empty Common AppData directory. Since it was empty, set to override local, and it would be c:\ProgramData, I wanted to delete it.

I removed the folder and all directories under Root disappeared from the screen.
I saved as a new package.
Opened the package in TMEdit.
I ended up with two ‘Root’s and Common AppData was still there.
When I tried to delete the bottom Root I got the following message in the bottom status bar: Last Operation: Error in File Add: Length cannot be less than zero.
Tried to delete Common AppData again and it did what it did before. (directories disappeared, then after reloading, had another Root, and directory was still there.)

I have screen shots of what it looks like but they did not past into the message. And I do not see an option to attach a file.

Please Log in or Create an account to join the conversation.

Time to create page: 0.315 seconds
Go to top